Sunday, February 24, 2013

Exchange 2010 Mailbox Move Hung at 95%

I'm doing a migration from Exchange 2007 to Exchange 2010 has run into an issue with some mailboxes hung at the status of "Completing". If you look at the log for the move, it indicates that it is at 95% and getting the final incremental data after the initial move. These moves were hung for a couple of hours in this state.

There are several suggestions for fixing this online:
  • Verify that AD permissions are inheriting to the user account.
  • Restart the Exchange Mailbox Replication Service
I verified the permissions and restarted the Exchange Mailbox Replication Service with no effect. After restarting this service, there were errors in the mailbox move log about the mailbox already being in the process of being moved and that it could not connect. My thought at this point is to restart services on the Exchange 2007 side to hopefully release those mailboxes

When I looked at the application log on the Exchange 2007 server, I noticed that there was an error about the Mailbox Submission Service not responding for 30 minutes. This added to my suspicions about the Exchange 2007 actually causing the original completing error.

After restarting the Exchange services on the Exchange 2007 server all was good. To allow the Information Store service to restart, I needed to suspend all of the queued moves. Until I did that, it hung at stopping.

After restarting, a couple of the moves that were completing failed and other completed. Not a problem, as moving those failed mailboxes again was easy enough.

Thursday, February 21, 2013

Default Gateway

Over the last few years we've had several instances of Windows 7 computers having a default gateway of assigned. In all cases, the computers were obtaining an IP address from DHCP.

This is a fairly well know issue with several products the use the Bonjour service for some networking services. References I've seen to Bonjour include iTunes and Adobe CS3. However, there are likely to be others.

The basic problem is the timing of service startup. If the Bonjour service starts before the networking is initialized, the Bonjour service adds a default gateway of which overrides the default gateway that you eventually get from DHCP.

There are several ways to fix this:
  1. Update your product. I've found several references online that indicate that the latest versions of the Bonjour service don't have this issue.
  2. Disable the Bonjour service. The only downside to this is that it may impact some functionality in the product.
  3. Manually remove the default gateway (route delete and the release and renew the IP address.
In my case, the Bonjour service was not installed. However, I did see references to the Bonjour service being an mDNS provider. This is multicast DNS and used to resolve names on a local network when DNS may not be properly configured. This is primarily for peer to peer name resolution. I believe iTunes uses this for local networking with devices such as Apple TV.

Our client did have a National Instruments mDNS Responder Service and disabling this service did resolve the issue. To further optimize this and keep any functionality in that service that might be required, I changed the startup type of service to Delayed. This allowed the networking services to configure before the service started and worked fine.

So, the final option for resolving this appears to be setting the offending mDNS service to a statup type of Delayed.

Office 365 Launch Event for Business

If you've wondered what Office 365 is all about and whether it's worthwhile for your business, you can check out an Office 365 webcast on Feb 27th. Several times are available.

Register here:
 A brief description of the event:
  • Learn how the new Office 365 can help people do
    their best work in a world of devices and service
  • Hear customers talk about how Office 365
    is transforming the way they deliver productivity
    tools across their organization
  • See how Office 365 delivers new experiences
    combining the power of social with collaboration,
    email and unified communications
  • Join in a live Q&A with Microsoft executives
    and product experts

Wednesday, February 13, 2013

Exchange 2010 SP3 Released

I wouldn't normally both to put a post up about a service pack being released, but this is an important one. This service pack for Exchange 2010 enables:
  • Coexistence with Exchange 2013. This SP is required before you add Exchange 2013 to an existing Exchange 2010 organization. However, you also need cumulative update 1 for Exchange 2013 which has not been released as of today (Feb 13, 2013). Exchange 2013 CU1 is scheduled for release sometime in Q1 of 2013.
  • Support for Windows Server 2012. Without this SP, you cannot install Exchange 2010 on a computer running Windows Server 2012.
  • Support for IE 10 in OWA. I've not tested it, but without the SP apparently OWA does not work properly with IE 10.
Related to support for Windows Server 2012 is support for PowerShell v3. Since Windows Server 2012 includes PowerShell v3, it stands to reason that you will be able to install PowerShell v3 on other versions of Windows Server running Exchange Server 2010. However, I have not yet tested this.

A Technet blog announcing the release is here: